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Desktop Client: How to solve "Item does not exist" errors on IGX document or diagram check in

Problem

When trying to check in a diagram or document using the iGrafx Desktop Client, an error dialog appears with the message "The item you are trying to access does not exist. It may have been removed." Clicking the details button reveals a "500" error with a timestamp.

Cause

This is a known bug that prevents check-in for diagrams that contain dead links. Your diagram contains repository links to objects that no longer exist in the connected iGrafx Platform.

Solution

To resolve this error, you have to find all shapes and objects within your diagram that contain links to repository objects (URL links are unaffected).
On each shape, you will have to remove the links that point to objects no longer present in the repository.
Once all dead links have been removed, the diagram or IGX document can be checked in again.



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