Desktop Client: How to resolve not being able to check in Documents or Diagrams due to "Name Exists" or "Invalid Pointer" errors
Problem
You may not be able to check in documents (or individual diagrams) and the Client will present you with an error dialog "An item already exists with that name" or "Invalid pointer" (with the detailed error message stating "Error Number: 0x80004003").
Cause
When you check out an item, iGrafx extracts it from the repository and places a copy in a working folder on your local drive (the working folder is controlled by the Repositories menu Options command; see Repository Options dialog box). When you make changes to a document, you are working with this copy of the item.
When using the "Save As..." functionality and through file corruption because of hard disk issues, the identifier connecting the version of the .igx
file on your computer (within your local repository folder) with the file in the repository can become out of sync. If this happens, the check-in process will fail with the above error messages.
Solution
Unfortunately, there is no way to restore the original identifier within your copy, but here are two ways to re-apply your changes to a fresh copy from the remote repository.
Alternative 1
- Open your local repository folder on your hard disk
- Find the affected IGX document's file
- Copy the file into a new folder outside of the local repository folder
- Go back into the client and undo the checkout of your IGX document by right clicking the item in the tree, selecting
Undo Check Out
and confirming - Check out your IGX document again
- Click File -> Open and select the file from step 3
- Go to the Document Components panel, right click the diagram with your changes and select
Copy
- Switch to the checked out IGX document, right click into the Document Components panel, right click and select
Paste
(it will automatically receive a new name) - Delete the old diagram by right clicking it in the Document Components panel and selecting
Delete
- Check in your diagram
- Check out your diagram
- Rename your copy of the diagram to the name it had previously
- Check in your IGX document again
Alternative 2
- Open your local repository folder on your hard disk
- Find the affected IGX document's file
- Copy the file into a new folder outside of the local repository folder
- Go back into the client and undo the checkout of your IGX document by right clicking the item in the tree, selecting
Undo Check Out
and confirming - Check out your IGX document again
- Click File -> Open and select the file from step 3
- With both files open at the same time, see the changes side by side and re-apply them to the checked out diagram
- Check in your newly applied changes (Do not use Save As, instead just SAVE the file)
Related articles
- Adding Desktop Client (IGX) Documents to a Repository
- Desktop Client: Resolving installation issues involving VBA
- Desktop Client: Enterprise Model warning when adding IGX file to repository
- Desktop Client: How to create a custom order for diagrams in an IGX document
- Desktop Client: Why is the automatic Swimlane-based relationship creation not working?