Skip to main content
Skip table of contents

Client: Why do I only have view capability (why can't I create or edit iGrafx files, why is there a lock)?

If you cannot create or edit iGrafx files, it is likely that it is because of one of the following reasons:

  1. iGrafx is not properly licensed, or your trial period has expired.
  2. You only have the Viewer application installed
  3. The file is marked as read-only (either in Windows or because someone else has the file open for edit, or you did not check it out of a repository).
  4. The document has been password protected.
  5. There is a problem with your installation.
  6. You are running simulation.

Each possibility is covered below:

You only have View (Viewer) functionality, due to incorrect license keys or an expired trial:

It is possible that you do not have all of the correct and valid or current licenses needed to enable full iGrafx functionality, and thus only have the iGrafx Viewer application. Ways to tell if you have the Viewer include if you cannot choose File > New (in iGrafx 2013) or if you only have a grayed out "From Template" choice in File > New (in iGrafx 2011 and prior).

To check the details of what licenses you have installed, and help debug why you only have the Viewer, do the following:

  1. Start iGrafx.
  2. From the Help menu, choose "About iGrafx"
  3. Click on the "Manage" button in the License Keys section of the dialog box.
  4. Click on each key listed that's enabled, and note the description of the key.

The description of the license key should help indicate the source of the problem, and it is probably because of one of the following reasons:

  1. Your free 30-day trial of the software (or 20 use, if the trial is not activated) has expired. If the details of a license key say that the Activation key and/or the trial key has run out, then please contact your iGrafx sales representative or purchase through our eStore in order to continue your work.
  2. You have incorrect or incomplete license keys entered. You may have incorrectly typed the license keys needed to use your iGrafx application, or have only entered one key (e.g. the activation key and not the product license key). Please ensure that all the correct keys have been entered into the license management dialog box, described above.
  3. Your license key didn't get completely installed, and the description of the key (when you click on it in the iGrafx Licensing dialog box) will say 'uninstalled'. This is probably a rights/permissions issue, and you need to have a full administrator (e.g. IT person) install the software on your machine.  

Only the Viewer is available in the Start menu Programs:

If you only have the Viewer in your start menu, it's possible that the viewer was the only application that was installed on your machine. If you go to the Start button in windows, choose Programs, choose iGrafx, and then only see the Viewer in the list of iGrafx programs, then you only have the Viewer installed. It's possible that the correct shortcut was not installed if someone else installed your software; please use the instructions above to check which keys are enabled to know which product you should have, and ensure the correct shortcuts do get installed.

If the shortcut is not the issue, you only have the viewer product and want to use the full version of iGrafx, you may request the keys to get a free 30-day trial, or purchase a license of the iGrafx product you wish to use. Please see http://www.igrafx.com for more information on iGrafx trials or the purchase of a license.  

Read-only (View-only) File:

If someone has marked the file Properties in Windows as Read-only, if someone else has the file open for editing in iGrafx and you then also open it, or if you've viewed (vs. checked-out) the document from a repository, the file will be marked as read-only and you may see a lock icon next to the arrow cursor when you move your mouse cursor to the diagram. This will make the file read-only (view-only) and will prevent you from editing the file. Either remove the read-only property in the operating system (in the Windows Explorer), have the other person finish their edits and save/close the file, or properly check the document out of the repository for editing.

The document is password-protected:

It is possible that someone has password-protected the document. The best way to determine if you have a protected document is pull down the "Tools" menu. The second entry down will be one of the following:

  • "Unprotect Document...": Your document is protected, and choosing the Unprotect Document command will allow you to enter the password to unprotect it.
  • "Protect Document...": If your document is unprotected, this command allows you to enter a password to protect it

If you have forgotten (lost) the password to the document, there is no way for you to unprotect the document, and you will no longer be able to edit it. You can, however, still open the document and see a read-only copy of the data. You can copy and paste this data to a new file for editing: Simply select (e.g. Select All with a Ctrl+A key combination), copy (Ctrl+C), and paste (Ctrl+V) the contents of each diagram (or other component) from the document to another document, and then edit that copy of the document. You can, of course, also re-create the contents of the document if desired.

There is a problem with your installation:

It is possible that your installation is incomplete or corrupt and needs to be repaired or re-done. We recommend you run a repair install (better would be to uninstall and reinstall, though this will cause a loss of user-specific settings such as where toolbars are located). Please ensure that when you run the installer you do so as an Administrator (e.g. right-click on setup.exe and choose Run as Administrator). If you do not have Admin rights to your machine, please have your IT department do this for you. The iGrafx Installation Guide may provide helpful information on installation options.

Running simulation; file locked to prevent edits:

A lock icon will appear on your cursor if you are running simulation (e.g. in iGrafx Process or Process for Six Sigma); you cannot edit the file while simulation is being run. If the 'Stop' button on the Modeling toolbar (the stop button is the square that looks like the stop button on a DVD player) is enabled or lit up, and you want to edit your file, then click it to ensure you have stopped running simulation.

If the above information doesn't help solve the problem, lease contact Support (via our website at https://itrax.igrafx.com/servicedesk/customer/portal/2) and provide the information requested.

JavaScript errors detected

Please note, these errors can depend on your browser setup.

If this problem persists, please contact our support.