Skip to main content
Skip table of contents

Client: How to copy/paste a diagram (or items in a diagram)

If you want to copy a diagram to another diagram -- copying everything on the diagram, including shape text and properties of the shape (e.g. for simulation purposes) -- you can do the following:

  1. View the iGrafx Explorer Bar (go to the View menu, and choose Explorer Bar; or click the Explorer Bar button on the Toolbox toolbar).
  2. Right-click (click your right mouse button) in the Explorer Bar listing on the diagram you wish to copy, and choose Copy.
  3. If you want to paste it into the same file, right-click (in the Explorer Bar) and choose Paste. If you want to paste into another file, open that file first, and then right-click and choose Paste. 

If you want to copy a section of the diagram (e.g. the shapes in some portion of your diagram) to another section of the diagram, then:

  1. Lasso select the items/section of the diagram (with your selector tool arrow cursor, press-and-hold the mouse button, dragging the cursor to draw a box completely around the things you want selected)
  2. Choose Edit > Copy (or Ctrl+c)
  3. Choose Edit > Paste (Ctrl+v)
  4. Move the items to where you want them to be. To move a shape, place your arrow cursor over the light gray (stippled) border of the selected shape(s) until you get the cursor with 4 arrowheads (one pointing in each direction of the compass), and drag (press-and-hold, drag, release) the mouse to where you want the items to be. 
JavaScript errors detected

Please note, these errors can depend on your browser setup.

If this problem persists, please contact our support.