Skip to main content
Skip table of contents

Client: How do I show multiple timelines in a Lean Value Stream Map (VSM)?

Starting in iGrafx 2013, you may have multiple timelines in a Lean Value Stream Map. From the Lean menu, choose Value Stream Map Properties, and then click the Lean Timelines page. On the Lean Timelines page you can manage multiple timelines; including duplicating existing timelines. Simply click the page for the timeline you want to customize. Once you have defined more than 1 timeline, each shape will go on a specific timeline, and you may set the active timeline for which timeline is used for new shapes. You may drag-and-drop timelines to new locations, and can even use the Lean toolbar to change which timeline shapes are on. See the iGrafx Help system (Help menu > iGrafx Help) for more information about multiple timelines.

Prior to iGrafx 2013, a Lean VSM diagram can only have 1 dynamic timeline, that updates based on data entered in Process step (shape) boxes, and it is positioned below all shape objects in the diagram. If you are using iGrafx 2011 or prior, depending upon what you're trying to accomplish with multiple timelines, there may be some methods to show what you want; particularly for graphical presentation purposes. Keep in mind how you want to reach a future state VSM, or to communicate how to eliminate waste from the value stream. Methods to consider prior to iGrafx 2013, depending upon your end goal, are:

  1. Hierarchy (Lean Data Rollup): If you are trying to have portions of a VSM have their own timeline, and are OK with them in separate diagrams but still related to the overall timeline for the VSM, then use Hierarchy. Use the Lean Data Rollup from other diagrams (with their own timelines) rolled up into the parent shape in a parent VSM. Please see the "How do I create hierarchy (functional decomposition) in my iGrafx diagrams?" knowledge base article, or the Help, for more information about how to create hierarchy in your VSM (this is a generic article; Lean hierarchy is near the bottom of the article).
  2. All on One Page: You want multiple sub-VSM's all on one page (e.g., for presentation purposes). If you want all your sub-VSM's on one page and being readable, there are various methods you may want to try:
  1. Page Setup: Go to File > Page Setup, and make the page bigger; and/or print at 100%-- instead of printed to 1 page wide by 1 page tall-- and print in poster mode and tape together to a big printout.
  2. Arrange Pictures: You can turn your separate VSM's (or sub-VSM's) into a picture, and then arrange in iGrafx or another application such as PowerPoint. For example:
  1. Copy and 'Paste Special': Take sections of another Lean VSM diagram in iGrafx, arrange the sections, and draw a few lines to connect them as needed. In particular, in iGrafx, do the following:
  1. Select the Timeline and/or shapes and associated timeline.
  2. Edit > Copy
  3. Edit > Paste Special, as an enhanced metafile picture
  4. Arrange > Convert To > Graphic; so lines can be drawn to/from the timeline and/or sub-assembly VSM.
  • Publish As: Publish As a picture, and then arrange the pictures as needed. For example, File > Publish As > PowerPoint (Publish to PowerPoint) and then arrange on one slide.
  • Offset Shapes: If you want separate data on one timeline for different sets of shapes, simply offset them vertically. For example, if you want a timeline for the information flow at the top of a VSM, and the material flow at the bottom of a VSM, then offset the two areas (e.g. information flow at top-left and material flow at bottom-right) so they are graphically not on top of each other; offset shapes in such a way that data is separate.
  • Not On Timeline: If the issue is that you have some shapes that are affecting the one timeline and you do not want them to, use the 'Not On Timeline' setting on some boxes to remove them from the single timeline. Please see the "Client: Timeline data for parallel paths in a Lean VSM" knowledge base article, or the Help, for more information about how to remove certain shapes from affecting the timeline.
  • Use Separate VSM's or Export/Import: If you want different calculations on the same data for what-if scenario's, you may want to consider the following methods:
  1. Use separate VSM's for your calculations. Use separate VSM diagrams for each 'what-if;' don't try to do all your analysis in one VSM (with the exception of showing more than one diagram in a VSM for presentation purposes; see item 2 above).
  2. Use Export/Import of Data: You may the Lean menu's 'Export VSM Table to Excel' and 'Import VSM Table from Excel' commands to export/import data to/from Excel. For example, if you wanted multiple timelines for showing different 'what-if' scenarios or impact of different Takt calculations, you could export to Excel, change data impacting timeline calculations, and then re-import the data so the timeline automatically updates based on the new data.
JavaScript errors detected

Please note, these errors can depend on your browser setup.

If this problem persists, please contact our support.