Skip to main content
Skip table of contents

Client: How do I share simulation modeling information between iGrafx files?

You can share modeling information-- including resource definitions, schedules, and other Scenario information used in simulation modeling-- in an iGrafx file with other files. This allows you to enter information once, and use (re-use) it many times.

Important Note:

If you simply want to help users navigate between files, and not share modeling data between files for simulation purposes, we recommend that you use the linking functionality. Select the shape you want to link from and from the Insert menu choose Link. See the iGrafx Help system (Help menu > iGrafx Help) for more information.

However, if you're interested in sharing simulation modeling information between files, please read on about how to do so.

Sharing Simulation Modeling Information Between Files:

To share simulation modeling information, use the following methods:

For Resources:

If you only have the iGrafx Client (e.g. FlowCharter):

Set up the Resource information in a Scenario in a document (file), and then do one (or more) of the following:

  1. Save the file as a template: Then whenever you create a new file, you can create it from the template and it will receive all the resource (and other Scenario) definitions you have made in your template file. Please see the end of this article for information about how to create and share templates.
  2. Copy and Paste the Resource Definition(s) to Other Files: In the Scenario window (which you can open from the document Components window), expand resources (or other definitions) and click on the definition you want to copy to select it. You will see a highlighted box around it. Copy that item using the Ctrl+C keys, and then paste it into your other file's Scenario by going to its Scenario window and using Ctrl+V.
  3. Copy and Paste the Entire Scenario: In the document Components window (from the File menu, choose Components), right-click on the Scenario and choose Copy. This copies the entire Scenario, including more than Resource definitions, so this may be more than you want if you only want Resource definitions. You may then paste the Scenario into other files by right-clicking in the Components window and choosing Paste.

If you have the iGrafx Platform:

The iGrafx Platform has a Resource Model (the repository Resources folder) that provides one centralized location for all resource definitions, including organizational structure. You can attach repository resources to your model in the Define Resources dialog box. When you link, the model obtains all repository resource definitions 'by reference.' This has the advantage that if the resource definition in the Central repository is updated, all related files will either automatically update (in the case of organizational structure or swimlane names) as well as being able to 'Update' the resource definitions explicitly.

For Any or All Scenario Information:

 For sharing any or all Scenario information, such as Schedules, Generator definitions, simulation setup, Scenario attribute initialization, monitors, and custom function definitions:

  1. Save the file as a template: You can setup the information you need in a document (file), and then save that file as a template. See the end of this article for more information about creating and using templates.
  2. Copy and Paste the Entire Scenario: In the document Components window (from the File menu, choose Components), right-click on the Scenario and choose Copy. This copies the entire Scenario. You may then paste the Scenario into other files by right-clicking in the Components window and choosing Paste. 
  3. Copy and Paste the Specific Scenario Definition(s) You Want to Other Files: In the Scenario window (which you can open from the document Components window), expand the Scenario definitions you wish to share, and click on the definition you want to select it. You will see a highlighted box around it. Copy that item using the Ctrl+C keys, and then paste it into your other file's Scenario by going to its Scenario window and using Ctrl+V.

To create a template, simply go to the File menu, choose 'Save As...' and ensure that the file type is 'iGrafx Template (*.igt)'. You can pick any name you'd like. Once you click the Save button, you will be prompted about saving the template in a special location. If you say 'Yes' to the prompt, iGrafx will show the template in the User Templates tab when you go to the File menu, choose New, and then From Template. You can also override the built-in iGrafx templates; See the iGrafx Help system (Help menu > iGrafx Help) for more information. 

For Diagrams:

You may share diagram information between files.

If you only have the iGrafx Client (e.g. FlowCharter):

You can copy and paste diagrams (components) between files using the context pop-up menu in the Document Components window. Simply right-click the component (e.g. diagram) to copy, choose copy, go to the file you wish to paste into (e.g. by using the window menu to switch to a diagram in that file, and then in the Document Components window right-click and choose paste.

If you have the iGrafx Platform:

You may use the 'Share into Active Document' command (in the Item menu in the Repositories menu) to share a diagram (or other component) between iGrafx files (items) within the same repository. Sharing allows you to only have to maintain one copy of the diagram in the repository; so if it is changed, the change is reflected everywhere that diagram is used. Sharing allows iGrafx simulation to treat the items shared as if they were one file, thus allowing simulating more than one file without having to copy and paste data. In order to share data between items, you must check out the item you want to share the data into, select which item in the repository you want to share, share that item (properly linking the newly shared component data into any hierarchy), and then check the modified data back into the repository.

If you wish to copy the component into the active document, you can use the Repositories > Item > Copy into Active Document command.

JavaScript errors detected

Please note, these errors can depend on your browser setup.

If this problem persists, please contact our support.