Skip to main content
Skip table of contents

Client: How do I share my data (via Print, Publish, Export, etc.) with people who do not have the iGrafx client?

The best way to share your Client work with others in the organization is save your work in iGrafx Platform repositories where they can be easily viewed and commented on by others within your organization.

In addition, you may:

  1. Print: Print your diagrams and other data (to hardcopy)
  2. Office: Publish to Microsoft® Office Word® and PowerPoint®
  3. PDF: Publish to PDF format, for viewing with a PDF reader such as Adobe® Acrobat Reader (in iGrafx 2007 and later releases).
  4. Web: Publish to an internet browser, web-ready (HTML, Java, or SVG) format. If you have the iGrafx Platform installed, you have browser-based access of all repository data; providing full annotation, cycle management, rights control, and labeling without having to go through a separate publishing step.
  5. Viewer: Download and install the free iGrafx Viewer (reader) application on the machine (desktop) of those people that do not have iGrafx.
  6. Export Graphics: Export your graphical diagram to another graphical format, such as PNG, JPEG or GIF pictures, TIF data, Encapsulated Postscript, etc. Use the Tools > Export Diagram command to export the diagram picture to another format.
  7. Copy and Paste: You may select some or all of your iGrafx data, then Copy and Paste to another application. We recommend using Edit > Paste Special in the other application for more choices when pasting. If you simply want a picture, we recommend 'Picture (Enhanced Metafile)' if the option is given.
  8. Export Table: Export your data to another format, such as Microsoft Excel®, using the Tools > Export Table command. 
  9. XML: Export your data to an XPDL Package, or to XML using the iGrafx XML (IGXML) schema, by loading the controlled release IGXML functionality [Contact your account manager] and then use File > Save As.

Before using one of the printing and publishing options, we recommend reviewing the settings in the Page Setup (from the File menu, choose Page Setup). You may use the Page Setup to control page boundaries including margins, header and footer information, number of pages and scale of pages, and whether you are printing to a book or poster type format. In addition, if you want a customized look to your diagram, or if you are printing a large diagram, you may want to use the diagram formatting (from the Format menu, choose Diagram) options. For example, the off-page connectors option in format diagram allows you to automatically 'separate' the lines into pages and place a connector symbol, optionally displaying the page numbers lines have gone to or come from.

If you are wanting to export your data to another application, such as Excel, please see the Knowledge Base solution titled "Can I export or import modeling data to or from Excel or other file format?"

Once you have setup for publishing, you are ready to use one or more of the various printing or publishing options. Each of the publishing options is outlined briefly below.

  1. Printing your diagrams: From the iGrafx Client File menu, choose Print. The print command allows you to choose which components (pieces) of your file to print, which order to print multiple components in (click choose and then click the up and down buttons), which printer or plotter to use, what page range to print, etc. If you are using the iGrafx Platform with your internet browser, use the File > Print to PDF command above the diagram.
  2. Publishing to Word, PowerPoint, or PDF: From the File menu, choose Publish As, and then the option you want. A dialog box allows choosing what to publish, where to publish it, and even options on how to handle links, header/footer, and other information. You must have the Office application you want to publish to on the same machine as iGrafx.
  3. Publishing to an internet browser, web-ready format: From the File menu, choose Publish As, and then choose Web Page. You may now choose where to publish your web-ready data, what components (pieces) of the file to publish, set options such as whether to output notes you've placed on shapes, and choose a web-ready format. Once you choose your desired web-ready output format, various options specific to that format will display. We recommend that you choose Java for the most flexible capability for user interaction and proper printing. The HTML or SVG formats may also be viable options for you. You do not need a web server in order for people to view the published output; you simply need to have ALL of the files published in the same folder, and available for someone with a Web browser (e.g. Internet Explorer) to view. If you email the files, ensure you email all files. It may be easier to send all files in a compressed or zipped format; e.g. using WinZip or the Windows compression utilities. The SVG format may not be supported by all browsers, and for Internet Explorer starting with version 9 (IE9) you will need iGrafx version 14.1 or later to view SVG published files.
  4. Exporting to a table or graphical picture format: From the Tools menu, choose either Export Table or Export Diagram.
  5. Copy and Paste your Diagram to another application. We recommend using Edit > Paste Special in the other application for more choices when pasting. If you simply want a picture, we recommend 'Picture (Enhanced Metafile)' if the option is given.

See the iGrafx Help system (Help menu > iGrafx Help) for more information about printing, publishing, and exporting of iGrafx documents.

JavaScript errors detected

Please note, these errors can depend on your browser setup.

If this problem persists, please contact our support.