Skip to main content
Skip table of contents

Client: How do I set default formatting in my diagram for shapes, lines, text, etc.?

To set default formatting for any objects you create from this point forward, from the Format menu, choose Diagram, and then choose the Defaults tab and format the categories of objects you want. You may use the Document Defaults tab if you want the formatting to apply to all diagrams in the file (document). 

If you want to setup a re-usable template that you can choose every time you create a new diagram, then:

  1. Create a new diagram (e.g. File > New > Process).
  2. Format > Diagram, and use Document Defaults tab to setup the formatting you want. You may also use the Themes for coloring. See the iGrafx Help system (Help menu > iGrafx Help) for more information.
  3. File > Save As; choose the .igt (Template) type and give it a name. We recommend you click "Yes" to the prompt about saving in a default location that can automatically be found. See the "Default and Custom Templates" topic in the Help for more information.

To format existing objects, select them (the Edit > Select command can select multiple objects of the same type), and then use the Format menu commands (e.g. font, fill, line and border, shadow/3d, etc.).

JavaScript errors detected

Please note, these errors can depend on your browser setup.

If this problem persists, please contact our support.