Skip to main content
Skip table of contents

Client: How do I insert non-iGrafx files such as Word or Excel into my iGrafx diagram?

You may use the Microsoft Object Linking and Embedding (OLE) technology to insert, or embed, files of other types into an iGrafx file. iGrafx is an OLE client and OLE server application.

For example, to embed a Word or Excel document in an iGrafx document:

  1. From the Insert menu, choose OLE Object; which brings up the Insert Object dialog box.
  2. Choose Create from File.
  3. Browse to the file, select the file, and choose Open.
  4. Choose Display as Icon
  5. Click OK

However, please be aware that embedding (inserting) a file is different than linking to it. If you publish the file (e.g. to Word or PDF), the embedded object will not be available in the published output, nor will it be available in web published form such as when viewed through the iGrafx Platform. In addition, if you are using the iGrafx Platform, you may want to consider linking to the item in the repository instead, as anyone in your organization (with access to the repository) should be able to follow the link and access the data stored in the repository.

If you want to link to a file instead of inserting (embedding) it in the iGrafx file, you may do so. From the Insert menu, choose Link and fill in the dialog box as appropriate. See the iGrafx Help system (Help menu > iGrafx Help) or other articles in this Knowledge Base for more information on linking.

JavaScript errors detected

Please note, these errors can depend on your browser setup.

If this problem persists, please contact our support.