Skip to main content
Skip table of contents

Client: How do I create a link (HyperLink) from a shape to a repository item?

To create a link that can be activated (a.k.a. a hyperlink) from a shape to an item in a repository, do the following:

  1. Select (click on) the desired shape.
  2. From the Insert menu, choose Link.
  3. Click the Repository Link button on the left of the Add Link dialog box. This displays the Repository Explorer.
  4. Browse to the item in the repository that you want to link to.
  5. (Optional) In the Key Modifier field you have the option of selecting the key (e.g. Alt, Ctrl, or Shift) that will be required as the modifier when you double-click on the shape to activate the link. If you don't put in a key modifer, double-clicking the shape will activate (follow) the link.
  6. (Optional) Enter a description of the file or web page you linked to; otherwise, the full path name is used as the name.
  7. Click OK, to close the Add link dialog box and save your link.

Note that the shape will now, by default, have a link icon in the lower-right corner. That is a visual indicator that the link has been created; you can control this indicator by going to the Format menu, Choosing Diagram, and then editing on the Indicator tab.

You can now do one of the following to follow/activate the link:

  1. Right-click on (click your right mouse button when your cursor is on) the shape, and choose the link from the context (pop-up) menu, OR
  2. IF you created a key modifier, hold down the Key Modifier that you selected and double-click the shape. 

If you linked to an iGrafx document (file) in the repository, and want to link from the shape to a specific diagram within that iGrafx document, you will have to edit the link to specify which diagram to link to. In order to edit the link and specify the diagram, do the following:

  1. Edit the Properties of the shape. You can do this by right-clicking (click your right mouse button over) the shape and choosing properties, or clicking on the shape, and going to the Edit menu and choosing Properties.
  2. Select (click on) the Links page; on the left side of the Properties dialog box.
  3. Select (click on) the link you want to edit.
  4. Click the Edit button; near the upper-right corner of the Links page of the Properties dialog box.
  5. In the drop-down menu labeled "Link to Diagram:", choose the diagram you want to link to.

Note: In order to follow a link to a repository item, iGrafx must be able to store the linked-to item in your local repository folder (configured using the Repositories menu's Options command). Ensure you have the ability (security, adequate space, etc.) to create files in the local folder.

JavaScript errors detected

Please note, these errors can depend on your browser setup.

If this problem persists, please contact our support.