Skip to main content
Skip table of contents

.Chapter 2.4: New Diagram Experience

(warning) This feature is considered Early Access, and may be disabled on your instance. Your system administrator can enable it for the entire instance, and it can also be enabled on an individual level from your Profile.

Video Summary

Watch this video for an 8-minute summary introduction to the New Diagram Experience.

What's new in the New Diagram Experience

Major Changes

New and clean look-and-feel

We've given the interface a complete overhaul with a clean, modern and consistent look. Updated icons and a new floating design contribute to a wide-open and easy-to-use diagram space. It's a big set of visual changes that cut through the clutter and let you focus on what you need to do.

Pan and scroll improvements

Panning has changed to use a right- (or middle-) button drag. Or, you can use space bar + left-button drag. We've also vastly improved the performance and accuracy of scrolling with a touchpad.

Lasso selection at your fingertips

A left-mouse drag at any time does a lasso selection. It's so easy now, it no longer even needs a toolbar button.

Easy checkin and checkout

One clearly labeled button in the main toolbar indicates whether the diagram is checked out. The same button lets you check it in and out.

Say goodbye to the menu bar

You'll find most of what was in the old File menu in the app menu, the first item in the main toolbar. The Arrange menu has been replaced by the arrange panel. The functionality of the old View menu has moved to a couple spots. 

  1. Panels such as the comments list or the shape legend are now available in the side toolbars.

  2. The rest of the view menu has moved to the view toolbar

For more details on these, just keep reading.

Introducing the view bar

Located in the lower-right corner, the view bar provides one-stop access to functions such as updating the zoom level, toggling full-screen mode, and accessing features previously found in the View menu.

Metrics toggles

Select "Metrics" in the view bar's "More options" menu and you'll get three more buttons in the view bar. These buttons each toggle the visibility of one of the Metrics windows. 

Fast access to all side panels

Vertical side toolbars are now available on both the left and right side of the diagram space. This gives you the flexibility to organize them however you like (see below) and easily open up two panels at a time. Panels that previously needed to be accessed via the View menu (Shape Legend, Comments List, Describes List, and Paths) are now found in the side toolbars.

Easily customize your side toolbars

You can simply drag the buttons around to re-order your sidebars. You can even drag items between sides. If you remove all the items from a bar, it will vanish until you add one back.

Select "Customize side panels" from the view bar menu for more customization options. From here you can add and remove toolbar items, choose from a selection of preset options, and swap the left or right sides. You can also expand or collapse each toolbar.

Styles and arrange panels 

Looking for the fill / line / font options that used to fill up the main toolbar? You'll find them all nicely organized in the new Styles panel. 

All of the options that were in the Arrange menu before — including the spacer tool —  are now in the new Arrange panel. This makes doing multiple arrange operations a snap.

Lane label changes

We're using a new, tooltip-like strategy for the always-visible labels for lane and phase headers. This approach meshes well with the new floating UI. Bonus: it also takes up much less screen space than the previous fixed header areas.

One-stop shopping for narratives

The narrative button and drop-down in the top-right auxiliary toolbar allow you to run different narratives quickly. These include the process narrative, SOP (if enabled), and an option to pick a narrative of your choice. None of these are new options, but now they are all in one place.

Apps button

The auxiliary toolbar is the home to our new Apps button, with access to solutions like Diagram Compare and, coming soon, Simulation. (Diagram compare is also available in the main application menu in the main toolbar.)

Smaller changes

Spacer tool stays active

The spacer tool now stays up and ready to go after using it once. To get back to regular editing, you can click once without dragging, press either the escape key or Ctrl+M, or press the Done button in the arrange panel.

New grid choices

In the view toolbar's menu, you'll find the grid controls. You can turn the grid off or choose one of two different looks. Pick from the classic lines, or choose dots, an updated style we think you're going to like.

Side toolbar expand / collapse moved to customization UI

To keep the screen as uncluttered and well-organized as possible, the buttons to expand or collapse the side toolbars are only shown in toolbar customization mode.

Find-in-diagram and undo / redo made visible

These commonly-used commands are now easily accessed in the main bar, in the top-left of the diagram area.

Updated visuals for the text editing toolbar

The popup toolbar shown while editing shape text shares the same great look as the rest of the new diagram experience.

Moveable navigator window

You can now position the navigator window anywhere you want by dragging its title bar. It also has a clean new look.

Fit to content knows about toolbars and open pages

Fit to content now considers toolbars and open pages when determining the new visible area of your diagram.

Simplified page names

Some page names have been updated:

Shape Libraries is now Shapes

Diagramming Properties is Diagramming

Automation Properties" is Automation 

Comments List is Comments

Shape Numbering is Numbering

FAQ: Quick, where do I find...

The lasso select tool?

You can now drag any time with the left mouse button to lasso select.

The pan / scroll functionality?

Drag with the center or right mouse button, or press space while dragging with the left button.

The Comments List, the Describes List, the Paths Panel, or the Shape Legend?

These are all available as side-bar pages now.

Check-in and check-out?

Now one prominently-labeled button in the main toolbar.

Other things that used to be in the File menu?

Found under the app menu, the first icon in the main toolbar.

The Arrange menu?

All of the same operations are available now in the Arrange side-bar panel.

The formatting and styling controls that were on the main toolbar?

These are now available in the Styles side-bar panel.

The zoom controls?

Now in the bottom-right view bar.

The full-screen button?

Also in the bottom-right view bar.

Options to view the grid, page breaks, or headers on-screen?

Click the "more options" menu in the bottom-right view bar to access these options and more.

Language grid, metrics, or the navigator?

Also in the bottom-right view bar menu.

Diagram compare?

Under the Apps button in the top-right auxiliary toolbar.

Narrative?

Under the Narrative button and drop-down in the top-right auxiliary toolbar.

Simulation?

Under the Apps button in the top-right auxiliary toolbar.

JavaScript errors detected

Please note, these errors can depend on your browser setup.

If this problem persists, please contact our support.