About the Desktop Client
What the iGrafx Desktop Client is, the license levels it comes in, how it works with and without a Process360 Live repository, and how you sign in.
Client: Use Show only Approved Items menu…
The Show only Approved Items command in the Repositories menu allows you to limit the repository view to only those items that have already been approved.
Connect to a repository
Sign the iGrafx Desktop Client in to a Process360 Live repository, on either the iGrafx Identity Solution or the classic iGrafx Login.
Client: What steps should I follow in order to…
This article applies to iGrafx Process and iGrafx Process for Six Sigma client tools. Simulation is not yet available via web-authored diagrams.
"Run-time error" or "Compile error in hidden…
Problem
Client: What's the difference in checking out a…
The repository window shows different kinds of icons for iGrafx files, depending upon what level of detail you're looking at within the iGrafx file (document). For example, when looking at the file/document overall, the icon shows 'stacked pages' (or stacked sheets of paper), and when exploring into the contents of the file, you will see the 'diagram' icon (a flowchart with different shapes), and may see other icons for other types of components in the file.
Desktop Client: "Unexpected file format" opening an IGX file…
Problem
Desktop Client: "You are already connected to…
This is not an error. You probably are connected to the repository and don't realize it.
Desktop Client: "You are already connected"…
Problem
Desktop Client: Action cannot be completed…
This article applies to the iGrafx Process for Six Sigma Desktop Client
Desktop Client: Active transaction limit in…
This article applies to iGrafx Process and iGrafx Process for Six Sigma Client tools
Desktop Client: After opening a Visio file, how…
After opening your Visio file with iGrafx, it will convert each page into a separate diagram by default. However, in the Open dialog box, when a Visio diagram is chosen, there is an Options button shown. One of the options is to choose to take each Visio page and combine into tiled pages on a single iGrafx diagram, when possible. So to automatically get multiple pages into one page:
Desktop Client: API authentication method for…
API Authentication Method
Desktop Client: Are there limits built into the…
This article applies to iGrafx Process and iGrafx Process for Six Sigma Client tools
Desktop Client: BPMN data artifact: How to…
Starting in iGrafx 2011, you can draw lines directly into and out of graphical objects, so you can show directionality of data flow by drawing lines.
Desktop Client: Can I change the zoom or size…
You cannot alter the zoom level or size of the image in full screen mode.
Desktop Client: Can I control the order that my…
No. In general, iGrafx does not provide control over the order extension projects are loaded in, and therefore does not recommend creating dependencies among Extension projects.
Desktop Client: Can I convert my Lean VSM…
While there is no automatic conversion between the Lean Value Stream Map (VSM) and Process type diagrams, there are methods you may want to consider if you want to take material/process flow from one type of diagram to the other.
Desktop Client: Can I delete the iGrafx…
After successfully installing iGrafx, you may delete the folder containing installation files (e.g. C:\\igrafxXXXX) if you are sure that you will no longer need the installation files. Keeping these files is like keeping an installation CD copied on your hard drive.
Desktop Client - Process Narrative Extension
The Process Narrative is an iGrafx desktop client extension that takes data from an open document (an ‘.igx’ file) to produce and format a report stored as a Microsoft Word document. It is not shipped with the product but can be requested via the iGrafx Support Portal or by contacting your iGrafx Account Manager. It is installed just like any other desktop application. See "Notes" below for extending the reports available.
Desktop Client: Can I export or import modeling…
Yes, you may export some diagram information to Excel or other format; it depends upon diagram type which method and format you may want to use.
Desktop Client: Can I mix running the latest…
If you are considering running a mixed version deployment, where some users are at one major version of iGrafx (e.g. A.x), and other users are at a different major version (e.g. B.x), please note that we do NOT recommend running iGrafx versions in a mixed version environment.
Desktop Client: Can I run two different…
No. You may not install, nor run, two different versions of iGrafx on the same machine at the same time.
Desktop Client: Can I use a latest version…
You may NOT use an older iGrafx client version with a later iGrafx Platform. This type of mixed version environment is not supported. Your older client will not be allowed to connect.
Desktop Client: Can I use older repositories…
While you can sometimes use the latest iGrafx Client with an older repository, we do NOT recommend, nor support, having the latest major version of the iGrafx client software edit data in repositories that are also being edited from iGrafx clients of an earlier version. This configuration should be a "stop gap measure" only as you work to upgrade ALL clients to a later (or the latest) version.
Desktop Client: Can I use swimlanes in my Lean…
Yes, iGrafx makes the swimlane functionality available in a Lean VSM diagram. You may insert swimlanes, and/or use the Swimlane Manager.
Desktop Client: Can iGrafx Japanese diagrams…
Yes, with one exception regarding links. When using an English version of Acrobat to view Japanese PDF files created by iGrafx, link names that may be associated with a graphic shape are not rendered correctly by the English version of Acrobat. Japanese Acrobat displays link names correctly.
Desktop Client: Can iGrafx open a Visio File…
iGrafx can open and convert (translate, import) Visio files by opening them in iGrafx. To open a Visio file, go to the File menu, and choose Open. In the Open dialog box, set the Files of Type drop-down menu to Visio, and browse to where your Visio file is.
Desktop Client: Can iGrafx perform Monte Carlo…
This article applies to iGrafx Process and iGrafx Process for Six Sigma Client tools
Desktop Client: Can Multiple Processes in the…
This article applies to iGrafx Process and iGrafx Process for Six Sigma Client tools
Desktop Client: Cannot checkout documents -…
Problem
Desktop Client: Cannot make last phase smaller…
The phases will always go to the edge of the page if you have a single Portrait style page set in Page Setup. If you choose a Landscape page orientation, you can shrink the last (right-most) phase to be smaller than the page, as long as you don't try to shrink it smaller than a portrait style page.
Desktop Client: Changes to the FMEA sheet in…
The password protecting the FMEA sheet is "igxpass".
Desktop Client: Check Your Model Before Simulating
This article applies to iGrafx Process and iGrafx Process for Six Sigma Client tools
Desktop Client: Compile error in hidden module:…
The error "Compile error in hidden module: ThisShapeClass" may occur when opening a diagram with, or clicking on, a Intelligent Shape from the Modeling/Analysis palette. This is a Visual Basic for Applications (VBA) error, and is related to your install of iGrafx and permissions on your machine.
Desktop Client: Crash with error message "Fatal…
Problem
Desktop Client: Dealing with Roaming Profiles…
Problem
Desktop Client: Dialog box window does not…
If the dialog or window you expect is not showing up, it is likely the result of the being in a location where you cannot see it, perhaps because of changing your screen resolution to a lower resolution value than you had previously, or because you had multiple monitors and are now using only one monitor.
Desktop Client: Disappearing (Hidden) Org Chart…
Problem:
Desktop Client: Do I need to uninstall the…
Generally it's not necessary to uninstall the prior version of the following iGrafx products before installing a new version:
Desktop Client: Do I uninstall the trial of…
There is no need to uninstall the trial version of iGrafx when you purchase the full version of the iGrafx product.
Desktop Client: Do I use layers for hierarchy…
Layers should NOT be used for creating hierarchy, or hierarchical decomposition of your diagrams.
Desktop Client: Does iGrafx client run on Apple…
iGrafx client tools are tested and supported to run on any hardware that is ”natively” running Microsoft Windows. This means that if the machine “boots” to Windows, and there is no other operating system running or being interacted with, iGrafx will run on it.
Desktop Client: Does iGrafx have a template for…
Yes, iGrafx provides a template to create a Pick Chart, also known as a PACE Prioritization Matrix. The template helps identify areas by placing items in a quadrant based on whether it has a Big or Small Payoff, and whether it is Easy or Hard to Implement. The Pick Chart name is common among Six Sigma circles, while PACE may be more common among Lean circles.
Desktop Client: Does iGrafx support unicode text?
You may use Unicode text in iGrafx.
Desktop Client: Does publishing to PDF support…
For PDF/A, the primary goal is to make the PDF self-contained. Here's how the iGrafx graphical diagramming client (e.g. FlowCharter) addresses PDF publishing and issues in PDF/A:
Desktop Client: Ensuring Task Duration Accounts…
If a resource is (or resources are) required to perform a task, then the duration will be limited by when those resources are in schedule if you are running in Calendar mode. The duration is converted to some number of seconds. In addition it does matter if you're in Calendar mode or Compressed mode, as Compressed time has 'time conversion' to change what a 'day' or greater means; though Compressed mode does not use schedules, so resources will not be constrained by schedule.
Desktop Client: Enterprise Model warning when…
Problem
Desktop Client: Error / Failure Code 80004005…
When trying to open a visio file from the Windows Explorer by doing a right mouse click and choosing "open with" you may receive an 80004005 error and iGrafx crashes. If this occurs, open the file by going to the File menu in iGrafx, and choose Open.
Desktop Client: Error message "The current…
It's possible that you have a license key or a rights problem; the message given may indicate that the iGrafx software is unable to read the license keys.
Desktop Client: Errors on repository documents…
When using the Client with the iGrafx platform, it is possible that operations on very long pathnames or filenames can generate errors. If the length of the path to a file, including the Client Local Repository Folder (set in Client tool, Repository Options dialog), the folders the file resides in, and the file name itself is longer than the length that the operating system (Microsoft Windows) or your database (e.g. Microsoft SQL Server) allows, then various errors are likely to occur.
Desktop Client: Excel doesn't open the file…
In log transactions, when logging to a text file, there is an option to have Excel automatically open a file after logging. This will not work in some cases.
Desktop Client: File and Component Name and…
In some cases, you may have decided to have multi-segmented file names or component names using a numbering scheme. It is possible, when viewing these items in the Document Components window or in the repository tree, that when the numbers reach a certain level, the items no longer appear in the sequential order.
Desktop Client: How are queues affected by…
This article applies to iGrafx Process and iGrafx Process for Six Sigma Client tools
Desktop Client: How can I control shape…
If you have linked diagrams together in a way that means there is no unique parent for a diagram (e.g. because diagrams link back-and-forth to each other, and/or create some infinite loops), iGrafx has to 'arbitrarily' pick what the hierarchical order should be. This can affect both the display of hiearchy and of shape numbering. A linking structure with no unique parent may cause the Document Components' "Diagram Hierarchy" view to not show what you expect. In addition, iGrafx may not pick the parent shape number you desire to use in hiearchical numbering, because there are multiple parents.
Desktop Client: How can I create a different…
Starting in iGrafx 2011 (v14), the default is to have an 'automatic' link indicator icon that matches the icon registered with the file system (the Windows operating system) display when you link to a file. So if you have iGrafx 2011 or later, and are creating a new file, this behavior is on by default.
Desktop Client: How can I create high…
You can export directly to PNG from iGrafx, and use the following method to get higher resolution than the default:
Desktop Client: How can I export my iGrafx data…
For the moment, the iGrafx XML interface, IGXML, is available under controlled release only. Please contact your account manager for more information.
Desktop Client: How can I identify and use…
This article applies to iGrafx Process and iGrafx Process for Six Sigma Client tools
Desktop Client: How can I increase the…
This article applies to iGrafx Process and iGrafx Process for Six Sigma Client tools
Desktop Client: How can I show rework in a Lean…
In thinking about how to handle rework, keep in mind that the main goal of VSM is to expose and visualize waste, and have a language and analysis method to eliminate that waste in the value stream. So as long as we keep in mind the goal of communicating wasted effort and eliminating it, vs. precise data analysis, there are 2 broad methods one might use:
Desktop Client: How do I add a license key to…
To add a license key (i.e. product license or activation key) to your iGrafx Client installation:
Desktop Client: How do I add Necessary NVA…
In general, Lean focuses only on eliminating waste or muda (Non-Value-Add or NVA) activities, and keeping Value-Add (or VA) activities. However, some people want to track the concept of Necessary Non-Value-Add (NNVA), also known as Business Value Add (BVA), which is activity that is 'required for the business' (e.g. regulatory or legal requirements) but that otherwise does not add value to the customer. While you want to seek to minimize or reduce BVA efforts, you may not be legally able to eliminate them.
Desktop Client: How do I change the currency…
With a document (file) open, on the Format menu, choose Currency to change currency values display in the Currency dialog box.
Desktop Client: How do I change the print order…
When printing, you may choose to print more than one component (e.g. diagram) at a time. When you've chosen more than one component to print, you may choose the order the components are printed in. To do so:
Desktop Client: How do I check my license keys…
You may check for the correct and valid or current licenses needed to enable full iGrafx functionality. To check the details of what licenses you have installed, and help debug any problems, do the following:
Desktop Client: How do I connect lines to other…
To allow lines to connect to other lines (instead of only to shapes):
Desktop Client: How do I connect shapes…
First, you cannot connect lines to graphics, so ensure you are using shapes. You can tell whether an object is a graphic by selecting it; if there is a red square 'callout point' in the middle of the object, it is either a graphic or text object.
Desktop Client: How do I convert an iGrafx file…
iGrafx does not support the conversion of the iGrafx file format into the Visio file format. Visio is a diagramming tool, while iGrafx is a diagramming, behavioral modeling, and simulation tool. A conversion from iGrafx to Visio would cause loss of data.
Desktop Client: How do I create a link…
To create a link that can be activated (a.k.a. a hyperlink) from a shape to an item in a repository, do the following:
Desktop Client: How do I create a user defined…
From the Model menu, you may choose "Functions...".
Predefine platform URL in client installation…
You want to push the URL of your iGrafx platform to your iGrafx Desktop Client users (i.e. Flowcharter), so they can pick it from the list of known URLs?
Desktop Client: How do I create hierarchy…
In Process and BPMN diagrams within a document, to create a new diagram in the same document and a hierarchical link to it, right-click and choose 'Add Subprocess' (available in iGrafx 2011 v14.1 and later versions). Name the diagram, and click OK. The new diagram is displayed for you.
Prepare for first run
Problem
Desktop Client: How do I customize the iGrafx…
This article applies to iGrafx Process and iGrafx Process for Six Sigma Client tools
Desktop Client: How do I display swimlane names…
To see the swimlane name at both ends of your diagram:
Process for Six Sigma Interaction Changes with…
Applicable Versions17.7.1.1276 and newer
Desktop Client: How do I Edit and Write to…
In order to edit iGrafx '.igx' format files, you need to purchase an appropriate version of the iGrafx authoring tool. If you want to view iGrafx '.igx' files created by someone else, iGrafx offers a free Viewer application on the iGrafx website. Please see the iGrafx website (http://www.igrafx.com) for more information.
Desktop Client: How do I ensure my external…
This article applies to iGrafx Process and iGrafx Process for Six Sigma Client tools
Desktop Client: How do I Export and Import Data…
You can export VSM data from iGrafx to an Excel spreadsheet with default or custom templates, change values in the spreadsheet, and import VSM data back into iGrafx. Lean data import and export commands are on the Lean menu.
Desktop Client: How do I export to PNG format?
Using the Page Setup dialog, one needs to set the page to 1x1 and make the custom page size square prior to export . This guarantees a square export.
Desktop Client: How do I Freeze Panes to get my…
In order to lock the screen as you scroll:
Desktop Client: How do I generate detailed…
This article applies to iGrafx Process and iGrafx Process for Six Sigma Client tools
Desktop Client: How do I get a Link Event shape…
The page linking in iGrafx can be automatic or manual.
Desktop Client: How do I get an activity to…
To get an activity to cross a swimlane boundary, use the Ctrl (Control) key, as follows:
Desktop Client: How do I get separate decision…
In order for iGrafx to automatically and uniquely name a line coming out of a decision diamond shape, it must come out of a unique location on the shape that does not already have a line leaving that point. In other words, you must use different locations when drawing your line from the Decision to get to separate named paths. If you draw two or more lines from the same point, then they will all be labeled with the same decision case.
Desktop Client: How do I get the full set of…
The full set of shapes that are available from iGrafx do not install by default when installing the iGrafx client applications (e.g. FlowCharter or Process for Six Sigma). You must do a Custom install of the software to have the full set of palettes available in the iGrafx applications.
Desktop Client: How do I handle shifts with…
In general, accounting for shifts with different numbers of operators or hours is more detail than necessary in a Lean VSM. Lean methodology is about getting rid of waste-- e.g. finding and eliminating inventory-- vs. modeling the Value Stream down to the exact details. So Lean practitioners tend to summarize detail like multiple shifts of varying lengths into an overall average.
Desktop Client: How do I insert non-iGrafx…
You may use the Microsoft Object Linking and Embedding (OLE) technology to insert, or embed, files of other types into an iGrafx file. iGrafx is an OLE client and OLE server application.
Desktop Client: How do I install or change…
In order to have a specific language available in iGrafx, you must first install it. You may select among the available languages to install for iGrafx by performing a Custom installation.
Desktop Client: How do I know if my BPMN…
BPMN has a strict set of rules, governed by the functional specification produced by the Business Process Management Initiative (BPMI) group of the Object Management Group (OMG). See http://www.bpmn.org for the latest specification.
Desktop Client: How do I link from a non-iGrafx…
You can link to any item in the repository by using the URL from the iGrafx Platform, as long as the application/document you're trying to link FROM allows hyptertext/web links.
Desktop Client: How do I make Web (Java, HTML,…
Once you have published your iGrafx diagram(s) to a Web format, using the File menu's Publish As Web Page command, you will have many different files created.
Desktop Client: How do I model unscheduled or…
This article generally applies to iGrafx Process and iGrafx Process for Six Sigma Client tools where simulation is possible. The setup, however, can be defined by iGrafx FlowCharter.
Desktop Client: How do I override (replace) the…
This solution assumes you are familiar with creating templates, and that you have appropriate permissions and/or company approval to customize your iGrafx installation.
Desktop Client: How do I print diagram shape…
Notes added to a shape, with the View menu's Note command (or by selecting the shape and pressing the F6 key), will not automatically print. You must first tell iGrafx to output shape notes.
Desktop Client: How do I print the Notes?
Printing Notes is an option in the Page Setup dialog box. To print the notes,
Desktop Client: How do I properly represent a…
In order to account for a batch at a single step, one way to do so is to use a number greater than one (1) for the number of operators on the process step. If you are accounting for a batch as a standard set of pieces that move through the entire Value Stream, then you may want to consider redefining the batch as a single piece, and adding a note or custom property to indicate the batch size. This article describes in more detail how to handle batching at a single step.
Desktop Client: How do I repair my installation…
If you are experiencing problems that are likely related to a bad installation of iGrafx, such as missing templates or menu items, errors when starting the software, etc. you may wish to do a repair install or uninstall/re-install. Please note that you need to have proper permissions (e.g. Administrator rights) to properly install or repair software.
Desktop Client: How do I restrict (prevent)…
You may prevent someone from printing the contents of a diagram from within iGrafx by placing the content on a layer that does not allow printing.
Desktop Client: How do I set default formatting…
To set default formatting for any objects you create from this point forward, from the Format menu, choose Diagram, and then choose the Defaults tab and format the categories of objects you want. You may use the Document Defaults tab if you want the formatting to apply to all diagrams in the file (document).
Desktop Client: How do I share my data (via…
The best way to share your Client work with others in the organization is save your work in iGrafx Platform repositories where they can be easily viewed and commented on by others within your organization.
Desktop Client: How do I share simulation…
You can share modeling information-- including resource definitions, schedules, and other Scenario information used in simulation modeling-- in an iGrafx file with other files. This allows you to enter information once, and use (re-use) it many times.
Desktop Client: How do I show more data on the…
You can add data to the timeline in an iGrafx Lean Value Stream Map (VSM) timeline.
Desktop Client: How do I show multiple…
Starting in iGrafx 2013, you may have multiple timelines in a Lean Value Stream Map. From the Lean menu, choose Value Stream Map Properties, and then click the Lean Timelines page. On the Lean Timelines page you can manage multiple timelines; including duplicating existing timelines. Click the page for the timeline you want to customize. Once you have defined more than 1 timeline, each shape will go on a specific timeline, and you may set the active timeline for which timeline is used for new shapes. You may drag-and-drop timelines to new locations, and can even use the Lean toolbar to change which timeline shapes are on. See the iGrafx Help system (Help menu > iGrafx Help) for more information about multiple timelines.
Desktop Client: How do I show percent good…
In your Lean Value Stream Map (VSM), particularly if it is for an office (transactional vs. manufacturing) environment, you may have been taught to show a "First Pass Yield (FPY)" or "Percent Correct and Accurate (%C&A)" number instead of a "Percent Defective (Defect%)". In addition, you may want to calculate the Rolled First Pass Yield (Rolled FPY) or Rolled Throughput Yield (RTY) number to show the actual yield of the process.
Desktop Client: How do I simulate a Lean VSM to…
Simulation, such as Discrete Event Simulation (DES), is not possible in a Lean VSM type diagram. Simulation is available in the iGrafx Process or Process for Six Sigma products, using a Process or BPMN type diagram.
Desktop Client: How do I tell if a particular…
This article applies to iGrafx Process and iGrafx Process for Six Sigma Client tools
Desktop Client: How does iGrafx handle more…
In the Lean Value Stream Map diagram type, iGrafx will use the number of operators that you enter for a step in its calculations of Production Time and Capacity, and essentially treats the number of operators as the number of parallel and identical operations being performed at a step.
Desktop Client: How is iGrafx simulation…
This article applies to iGrafx Process and iGrafx Process for Six Sigma Client tools
Desktop Client: How is Inventory Lead Time…
To calculate the Inventory Time (or Lead Time) from a particular inventory step that has an Inventory Amount specified in a Lean VSM, iGrafx can use two different methods: 'Based on Takt Time' or 'Based on Activity Capacity'. Choose whichever method works best for the Value Stream Map analysis that you are doing. Some people argue that calculations based on Takt time should be used, since it is the goal that you wish to produce at, while others argue that the current state is probably operating based on the actual capacity of the steps to consume inventory. Either way, please do not lose sight of the fact that any inventory is non-value-add (NVA) and should be minimized.
Desktop Client: How to copy/paste a diagram (or…
If you want to copy a diagram to another diagram -- copying everything on the diagram, including shape text and properties of the shape (e.g. for simulation purposes) -- you can do the following:
Desktop Client: How to create a custom order…
If you create multiple diagrams within one IGX Document using the iGrafx Desktop Client, it is likely you want them displayed in a certain order within the Client and when browsing the iGrafx Platform.
Desktop Client: How to customize the activity…
Customizing the shape in the library (on the Toolbox toolbar), if necessary:
Desktop Client: How to determine Activity ID's…
This article applies to iGrafx Process and iGrafx Process for Six Sigma Client tools
Desktop Client: How to ensure process is under…
This article applies to iGrafx Process and iGrafx Process for Six Sigma Client tools
Desktop Client: How to gain access to a checked…
IGX documents or diagrams that are currently checked-out by a different user cannot be deleted, moved or modified. This article explains how an administrator can get access to the diagram's latest checked-in version ⚠️ All changes done in the working draft will be lost when undoing the checkout.
Desktop Client: How to get Poisson arrivals in…
This article applies to iGrafx Process and iGrafx Process for Six Sigma Client tools
Desktop Client: How to have different decision…
The simplest method to have a complex decision, based on the value of an initial decision in an attribute, is to have more than one decision shape. However, you can also have user-defined functions keep decision values, and use those in a decision expression.
Desktop Client: How to make phases smaller…
When you grow the right edge of a phase to the right, it will move all contents in the next phase (if any) to the right, giving you more room in the current phase to add shapes. However, if you shrink the phase by moving the right edge of the phase to the left, you can end up overlapping content that is in the phase. In other words, it will not move the phase line boundary, but will shrink the phase, pulling objects to the right of the phase over to the left as well.
Desktop Client: How to reset the "Don't…
The client offers the option to not display certain alert messages, e.g. upon deleting a Describes Relationship.
Desktop Client: How to resolve not being able…
Problem
Desktop Client: How to simulate seasonality of…
You can simulate seasonality by using the “Timetable” generator type.
Desktop Client: How to solve "Item does not…
Problem
Desktop Client: How to troubleshoot…
We will first cover general installation trouble-shooting methods, and then reference other articles on specific error messages and specific steps to address the error.
Desktop Client: I converted my Visio file to…
Your additional pages may have been converted as separate diagrams when brought into iGrafx.
Desktop Client: I'm having problems printing;…
This is a generic problem-solving overview for printing (and other problems), and our Knowledge Base has more specific articles on known printing issues that you may find helpful as well.
Desktop Client: I've heard from Japan of a…
In Japan, there is a plug-in application that can be installed on top of FlowCharter called "SOX+" for doing Japanese Sarbanes Oxley compliance. This application can, for example, help you enter risk and associated controls that may be specific to the Japan's SOX auditing and reporting requirements/standards, into your iGrafx documents and create/output reports of risks and controls in order for the end users to prepare the required documents. For example, on iGrafx diagrams, you can see a red arrow icon to indicate risk and a green arrow-looking shape for the controls.
Desktop Client: IDEF0 lines disappear after…
This article applies to the iGrafx IDEF0 Client
Desktop Client: If your diagram is not…
1. There is not a default printer defined on your machine. Please ensure that a default printer is defined in Windows. This can be important for proper functioning of several iGrafx features; you should ensure a default printer is defined.
Desktop Client: iGrafx cannot open an ".abc" file
It is possible that you have a FlowCharter version 1 ".abc" extension file instead of a version 6 .abc file.
Desktop Client: iGrafx does not open my Visio file
The Visio 2010 files can be opened in iGrafx 2011 and later (including Origins) versions.
Desktop Client: Initializing and Accessing…
This article applies to iGrafx Process and iGrafx Process for Six Sigma Client tools
Desktop Client: Installation Error 1325 : not a…
When installing iGrafx, you may receive the following error message:
Desktop Client: Installation Error 1935
If error 1935 occurs during installation of the iGrafx Client
Desktop Client: Intelligent shapes encountering…
We have identified an issue when upgrading iGrafx and later using Intelligent Shapes that causes a "Compile Error" in certain cases. It is related to VBA type libraries and caches.
Desktop Client: Lean Best Practices in iGrafx
This article outlines some of the key best practices when using iGrafx to help accomplish process excellence through using a Lean methodology. This article assumes you are familiar with the concepts of Lean.
Desktop Client: Lean VSM: How can I change the…
In a Lean Value Stream Map, there is no way to globally change (use one step or command to change) the font of the process box name controlled by the secondary text area. For example, the text area in the process box that is labeled "Initial Process" in a new Lean VSM is a secondary text area.
Desktop Client: Linking to data in a SharePoint…
If you do not have an iGrafx repository, or you have the iGrafx repository and want to link to additional data stored in SharePoint, you may link from an object in an iGrafx diagram to data in SharePoint.
Desktop Client: Links to files in published PDF…
When using iGrafx to publish a diagram into a PDF format, you may discover that the links to external files cannot be opened.
Desktop Client: Microsoft ODBC Driver Manager…
iGrafx applications, all 32-bit, will work on computers running 64-bit versions of Windows without any changes.
Desktop Client: MindManager causes iGrafx…
Problem
Desktop Client: Missing columns after paste of…
When you choose to paste data copied from a Microsoft Excel Worksheet, it may be pasted in as an OLE object, preserving the fact that it is Microsoft Excel data. For example, if you copy the data in Excel, and then choose "Edit > Paste Special" and choose the "Microsoft Excel Worksheet" data type, the data is pasted in as a worksheet.
Desktop Client: msiexec - transforming table…
If you try to install an iGrafx Client application with a transformation of the admin installation (e.g. to install iGrafx via Admin install in German language), you may receive a transforming table error.
Desktop Client: My Template file is not in the…
You may choose to create a template, which is a customized starting point for your diagrams. Using the File menu, choose Save As, and choose "iGrafx Template" as the "Save as type."
Desktop Client: On my VSM diagram, I change…
If the inventory amounts, usually recorded in the inventory shapes (such as triangles, tombstones, inboxes, or clocks), were not changed in developing the Future State, the lead time will remain largely the same.
Desktop Client: Organization Diagram Options in…
iGrafx client tools (FlowCharter, Process, Process for Six Sigma)
Desktop Client: OrgChart menu and editing…
Even if you have the Organization Charts (a.k.a. OrgCharter or OrgChart) optional diagram type installed in iGrafx, it's possible that the OrgChart extension project has been disabled. For example, if you have loaded custom Visual Basic for Applications (VBA) extension projects, or someone has extended your installation with custom VBA code. If the OrgChart extension is disabled, you will not have the OrgChart menu in the menu bar (in the same menu as File, Help, etc.) nor will the OrgChart Builder and Data Editor dialog boxes display.
Desktop Client: OrgCharter error about…
If you attempt to import records into an OrgChart, and the ID field contains greater than 9 digits, you may receive the following error:
Desktop Client: Packaging iGrafx for Use with a…
If you are planning to install the iGrafx desktop Client (the 'Client') using a Software Management System (SMS), and in particular if you plan on using the SMS to determine which iGrafx Client products are licensed on the various machines of your network for the purpose of auditing which licenses are installed, it is suggested that you first package iGrafx as described below. The instructions below are guidelines, and you can of course customize them to best suit your organization’s individual needs:
Desktop Client: Page Setup Header, Footer,…
iGrafx provides the Restrict tab of the File > Page Setup dialog box, so that you may password protect and restrict editing of the Header, Footer, and/or Watermark for a diagram.
Desktop Client: Printing Multiple Process…
iGrafx will let you print out all the processes (diagrams) and other components that are a part of a single document. To do so:
Desktop Client: Problems printing or plotting…
When you try to print (or plot) using custom page sizes that are large, you may see problems with the quality of the printed diagram. This problem can happen with custom page sizes that don't map to anything close in the Printer Driver. By creating custom paper sizes in the driver that match the paper size in iGrafx, the mapping will be much better for printing.
Desktop Client: Process for Six Sigma…
This article applies to the iGrafx Process for Six Sigma Client tool.
Desktop Client: Publishing to Web with Linked…
iGrafx recommends using your iGrafx Client applications with the iGrafx Platform so that all models stored in the Platform are automatically visible in Web-ready format, and a publishing step is not necessary.
Desktop Client: Publishing vs. Copy and Paste
iGrafx offers several techniques for publishing process files to external formats including PDF (requires Adobe Reader), MS Word, MS PowerPoint, or other Web formats. These options are discussed in other KB articles, as well as the Help system included with the iGrafx application. Please consult these resources for strategy and information related to accomplishing your publication objectives.
Desktop Client: Repositories menu commands not…
If you select (highlight) an item in the Repositories window, unpin (hide, collapse) the window, and then go to the Repositories menu, you will find that commands in the Repositories menu are grayed (greyed) out.
Desktop Client: Repository query without any…
If you query by a label, and no results are returned, it's possible this is because you have not used labels in your repository. When you filter for a label in a query, and there are not any labels defined in the repository, the result will always be empty.
Desktop Client: Requirements for importing data…
iGrafx 2009 (version 13) and later uses the 32-bit Microsoft Access Database Engine drivers for importing data from Excel documents (\.xls and \.xlsx). These drivers are typically installed with Microsoft Office. In order for the Generators (or iGrafx in general, including Import Database Data) to read data from \*.xlsx files you need the Office 2007 versions or later installed. Additionally, if you have a 64-bit version of Office you will need to install the 32-bit drivers separately because they are not included with 64-bit versions of Office.
Desktop Client: Resolving installation issues…
Problem
Desktop Client: Saving a previous version file…
When opening a file created in an older version of iGrafx in a later version of iGrafx, the software remembers the source of the document. When you attempt to Save, the system will default to allowing you to save in the older iGrafx format by bringing up the Save As dialog. If you press OK it will warn you that you may lose any data from new features in the later version when saving back as an older version.
Desktop Client: Saving an iGrafx .igx file to a…
Users of the current iGrafx desktop client application have the ability to save files for viewing in previous versions of iGrafx.
Desktop Client: SharePoint Link Resolution…
Problem
Desktop Client: Sheet components only recognize…
As of iGrafx 2009, sheets support functions similar to those used in typical spreadsheet applications such as Excel. However, these functions are supported in English only. For example, the English function SUM works, but other language versions of the function (e.g. SUMA, SUMME) do not work when typed in directly by you.
Desktop Client: Should I use a Gateway to merge…
The iGrafx BPMN diagram type, and the BPMN specification, allow you to use either Gateway or Activity flow objects to merge multiple inputs from sequence flow in certain cases. So you are not always required to use Gateways to merge sequence flow.
Desktop Client: Simulated transactions are…
This article applies to iGrafx Process and iGrafx Process for Six Sigma Client tools
Desktop Client: Simulation End Time is over…
This article applies to iGrafx Process and iGrafx Process for Six Sigma Client tools
Desktop Client: Simulation error: Demand…
This article applies to iGrafx Process and iGrafx Process for Six Sigma Client tools
Desktop Client: Simulation Error: Simulation…
This article applies to iGrafx Process and iGrafx Process for Six Sigma Client tools
Desktop Client: Simulation error: simulation…
This article applies to iGrafx Process and iGrafx Process for Six Sigma Client tools
Desktop Client: Simulation warning: Activity…
This article applies to iGrafx Process and iGrafx Process for Six Sigma Client tools
Desktop Client: Six Sigma Best Practices in iGrafx
This article outlines some of the key ‘best practices’ when using iGrafx to help accomplish process excellence through using a Six Sigma methodology. This article assumes you are familiar with the Define, Measure, Analyze, Improve, and Control (DMAIC) methodology and techniques.
Desktop Client: Text in displayed Notes field…
Problem: Text in displayed in a Notes field or in shapes does not wrap, but instead appears as a single string of text.
Desktop Client: The shape palette on the right…
From the View menu, choose Shape Palettes. This will display either display a 'Gallery' collection of windows for Shape Palettes, Formatting, and Themes, or the Shape Palettes window.
Desktop Client: The Spell checker is grayed out…
If your Spell-checking functionality in iGrafx is grayed out, it could be because the software was not installed in such a way to allow you to have your own 'User Dictionary' file that you can read and write. To check, and correct, this do the following:
Desktop Client: The Tools menu Protect Document…
When you password-protect an iGrafx file (document) with the Tools menu Protect Document command, on subsequent open of the file, it cannot be edited until you use the Tools menu Unprotect Document command and enter the correct password.
Desktop Client: The Weibull distributions in…
Distributions can be added to a model with any iGrafx Client. Only iGrafx Process and iGrafx Process for Six Sigma Client tools can simulate the distributions.
Desktop Client: This application has failed to…
There are several problems that a default printer or a remote printer can cause.
Desktop Client: Timeline data for parallel…
Lean Value Stream Mapping (VSM) is a methodology to help reveal the waste in processes and then prioritize lean projects to eliminate that waste in a way that has the most beneficial impact on the overall system. Lean VSM is not a tool meant to analyze variability or dynamics in a process. Lean VSM is meant to be a static analysis of a snapshot in time, with a representation of average data. However, some limited benefit may be realized by representing parallel paths in a Lean VSM, given that the scope is still within the context of one product or product family (Value Stream) and keeping a relatively static nature to the data.
Desktop Client: Use of Attributes to Avoid…
This article generally applies to iGrafx Process and iGrafx Process for Six Sigma Client tools where simulation is possible. The setup, however, can be defined by iGrafx FlowCharter.
Desktop Client: Use of Random Number…
This article generally applies to iGrafx Process and iGrafx Process for Six Sigma Client tools where simulation is possible. The setup, however, can be defined by iGrafx FlowCharter.
Desktop Client: Using an Expression as a Count…
This article generally applies to iGrafx Process and iGrafx Process for Six Sigma Client tools where simulation is possible. The setup, however, can be defined by iGrafx FlowCharter.
Desktop Client: Using Templates in iGrafx IDEF0
This article applies to the iGrafx IDEF0 Client
Desktop Client: What are Activity location…
This article applies to iGrafx Process and iGrafx Process for Six Sigma Client tools.
Desktop Client: What are Simulation Snapshots…
This article applies to iGrafx Process and iGrafx Process for Six Sigma Client tools
Desktop Client: What BPMN constructs does…
iGrafx supports the graphical creation of Business Process Diagrams (BPD's) using the Business Process Model and Notation (BPMN) specification. iGrafx support for the latest BPMN specification on creating BPD's is quite extensive, and we have contributed directly to the specification via our participation on the BPMN committee.
Desktop Client: What do the colors and numbers…
This article applies to iGrafx Process and iGrafx Process for Six Sigma Client tools
Desktop Client: What does BVA (Business Value…
An activity is marked as BVA if the activity is required by the business, but the task does not contribute directly to the product or service.
Desktop Client: What does Time Conversion do in…
This article applies to iGrafx Process and iGrafx Process for Six Sigma Client tools
Desktop Client: What file formats can iGrafx…
iGrafx can read many different file formats, and write or publish to several formats.
Desktop Client: What happens to my files when I…
When you upgrade or move from one major version of iGrafx to the next version, including to the latest version, please consider the following upgrade tips:
Desktop Client: What is a Call Activity…
This article generally applies to iGrafx Process and iGrafx Process for Six Sigma Client tools where simulation is possible. The setup, however, can be defined by iGrafx FlowCharter.
Desktop Client: What is customer vs. production…
Takt time is the maximum time allowed to produce a product in order to meet customer demand, or the pace at which the process must run to successfully meet customer demand.
Desktop Client: What is Optima!
The iGrafx family of products are the successors to the Micrografx Optima! diagramming and discrete event simulation product, as well as the FlowCharter product. iGrafx can read and convert Optima and FlowCharter files. Optima! is no longer supported.
Desktop Client: What is the Export Control…
The Export Control Classification Number (ECCN) for iGrafx is #5D992 NLR.
Desktop Client: What is the HTML file naming…
The filename convention uses the Document Name plus the Diagram Name. This allows customers to save multiple documents (with same-named diagrams) to the same folder without overwriting HTML files.
Desktop Client: What is the Unlimited resource…
This article generally applies to iGrafx Process and iGrafx Process for Six Sigma Client tools where simulation is possible. The setup, however, can be defined by iGrafx FlowCharter.
Desktop Client: What kind of analysis can I do…
iGrafx FlowCharter is designed for visual analysis; you need iGrafx Process or above (e.g. iGrafx Process for Six Sigma) in order to run discrete event simulation analysis.
Desktop Client: What versions of Minitab work…
This article applies to the iGrafx Process for Six Sigma Client tool
Desktop Client: When I create a new IDEF0…
This article applies to the iGrafx IDEF0 Client
Desktop Client: When should I use different…
This article applies to iGrafx Process and iGrafx Process for Six Sigma Client tools.
Desktop Client: Where do I find a definition…
The iGrafx Help system contains a description of each built-in system function. To access this information:
Desktop Client: Where do I find documentation…
All iGrafx documentation on VBA API functions installs by default at C
Desktop Client: Where do I find information…
This article generally applies to iGrafx Process and iGrafx Process for Six Sigma Client tools where simulation is possible. Simulation reports, however, can be viewed by iGrafx FlowCharter users.
Desktop Client: Where is the troubleshooting…
Introduction:
Desktop Client: Why aren't my IDEF0 ICOM codes…
This article applies to the iGrafx IDEF0 Client
Desktop Client: Why aren't my transactions…
This article applies to iGrafx Process and iGrafx Process for Six Sigma Client tools
Desktop Client: Why do double-byte (Japanese or…
Typing double-byte characters, regardless of the language, requires you to press Enter to commit them. If you don't press Enter they are discarded. So, for example, if you are entering Chinese in a diagram in the Languages dialog box, ensure you click the Enter key after typing the characters; before moving on to the next box (cell) in the dialog.
Desktop Client: Why do I end up with blank…
Please check your view settings in Microsoft Word. Graphics will not (or may not) be displayed in a Word document unless you are in Print Layout or Web Layout. Go to the View menu in Word, and choose either Print or Web Layout. Can iGrafx print to a Large Format Printer (aka plotter)?
Desktop Client: Why do I only have view…
If you cannot create or edit iGrafx files, it is likely that it is because of one of the following reasons:
Desktop Client: Why do I receive a warning…
When you have an activity with multiple outputs specified, and there are more output options than there are physical lines exiting the activity, then there is one or more specified outputs that do not have a path to follow. Please check to make sure that you have one line for each output specified on the Outputs page and Normal tab.
Desktop Client: Why do the notes in a diagram…
PDF does NOT support rich text tooltips (e.g. underline, bold, etc.) at this time. In other words, PDF does not support all the formatting you've done; it's not an iGrafx limitation, it's a PDF (Adobe Acrobat) limitation.
Desktop Client: Why does the Generators dialog…
Problem:
Desktop Client: Why does the Generators dialog…
The External Data tab of the Generators dialog box will only show the first 500 rows of data to be read in and used.
Desktop Client: Why is iGrafx giving a Fatal…
iGrafx should not be crashing. If you are regularly seeing crash problems, or a certain sequence of steps always causes it to crash, it's possible that it is one of the following causes:
Desktop Client: Why is iGrafx installing into a…
On Windows 64-bit operating systems, there are two Program Files folders; one for 32-bit applications (the "Program Files (x86)" folder) and one for 64 bit applications (the "Program Files" folder). Applications such as iGrafx FlowCharter will install themselves into the 32 bit 'x86' folder if they are 32-bit applications. Said another way, if iGrafx is installing into the "Program Files (x86)" folder, you are installing the 32-bit version of an iGrafx application.
Desktop Client: Why is the automatic…
The client allows for Swimlane-based RACI assignments to be automatically generated when dropping a process object onto a Swimlane that describes a resource object.
Desktop Client: Why is the Repositories Share…
The Repositories Item menu 'Share Into Active Document' command may be grayed (greyed) out, or not available, for the following reasons:
Desktop Client: Will API functions in a new…
At each release we may add additional API functions, but the previous ones work the same way; unless there was a necessary fix of some type. The important thing is that we don't change the API access, so that previous extensions can continue to run appropriately.
Desktop Client: Will daylight savings changes…
The iGrafx software will not be affected by Daylight Savings Time (DST) changes. The iGrafx software does NOT need any patch or update for daylight savings changes. For Your Information One of the key provisions of the Energy Policy Act of 2005 is to extend Daylight Saving Time (DST) by approximately four weeks. In compliance with this provision, beginning in 2007, DST dates in the United States and Canada will start three weeks earlier (200 A.M. on the first Sunday in November).