# Google Analytics

Client: How to resolve not being able to check in Documents or Diagrams due to "Name Exists" or "Invalid Pointer" errors

Problem

You may not be able to check in documents (or individual diagrams) and the Client will present you with an error dialog "An item already exists with that name" or "Invalid pointer" (with the detailed error message stating "Error Number: 0x80004003").

Cause

When you check out an item, iGrafx extracts it from the repository and places a copy in a working folder on your local drive (the working folder is controlled by the Repositories menu Options command; see Repository Options dialog box). When you make changes to a document, you are working with this copy of the item.

When using the "Save As..." functionality and through file corruption because of hard disk issues, the identifier connecting the version of the .igx  file on your computer (within your local repository folder) with the file in the repository can become out of sync. If this happens, the check-in process will fail with the above error messages.

Solution

Unfortunately, there is no way to restore the original identifier within your copy, but here are two ways to re-apply your changes to a fresh copy from the remote repository.

Alternative 1

Use these steps if you have made a significant amount of changes to your diagram that you do not want to lose. Following these step does mean that all history of the diagram you are about to restore will be lost.
  1. Open your local repository folder on your hard disk
  2. Find the affected IGX document's file
  3. Copy the file into a new folder outside of the local repository folder
  4. Go back into the client and undo the checkout of your IGX document by right clicking the item in the tree, selecting Undo Check Out and confirming
  5. Check out your IGX document again
  6. Click File -> Open and select the file from step 3
  7. Go to the Document Components panel, right click the diagram with your changes and select Copy
  8. Switch to the checked out IGX document, right click into the Document Components panel, right click and select Paste (it will automatically receive a new name)
  9. Delete the old diagram by right clicking it in the Document Components panel and selecting Delete
  10. Check in your diagram
  11. Check out your diagram
  12. Rename your copy of the diagram to the name it had previously
  13. Check in your IGX document again

Alternative 2

Use these steps if you remember which changes you made to the diagram you want to check in and do not want to lose the history of the diagram within the iGrafx Platform. If you know which changes you made without seeing them on the screen, you can skip steps 1-3 and immediately start with undoing the checkout of your IGX document.
  1. Open your local repository folder on your hard disk
  2. Find the affected IGX document's file
  3. Copy the file into a new folder outside of the local repository folder
  4. Go back into the client and undo the checkout of your IGX document by right clicking the item in the tree, selecting Undo Check Out and confirming
  5. Check out your IGX document again
  6. Click File -> Open and select the file from step 3
  7. With both files open at the same time, see the changes side by side and re-apply them to the checked out diagram
  8. Check in your newly applied changes (Do not use Save As, instead just SAVE the file)