# Google Analytics

Client: Can I export or import modeling data to or from Excel or other file format?

Yes, you may export some diagram information to Excel or other format; it depends upon diagram type which method and format you may want to use.

The method to use to export diagram data for diagram types OTHER THAN a Lean VSM is through the Tools menu, using the Export Table command. For Lean Value Stream Maps (VSM's), you may use the Lean menu's Export and Import commands.

You can read about the export commands in the Help system. From the Help menu in iGrafx, choose iGrafx Help. Look for the topic called 'Exporting a Table', or search for a term such as Exporting to Excel. You may also want to search on Lean export if you're working with a Lean VSM.

For diagrams other than Lean VSM (those that are NOT Lean VSM diagrams):

We suggest that you go into tabular view before exporting, as it will help populate your export fields automatically. From the View menu, choose the Tabular command. We recommend you then go to the View menu and choose Columns, to adjust what information is shown in the tabular view.

Once you have your initial list of fields to export, perform the Tools > Export Table command. You can now add to, or take away, from the resulting list by dragging-and-dropping to/from the list of properties and the list of what is to be exported.

We recommend that you select the 'Include Headers' checkbox option if you want a header row in your exported data.

Once you have set your list of properties to export, you can then export your data to a file (e.g. to a text file that you can open with Excel), or to the clipboard so that you can paste the data directly into Excel.

Please note that the Export Table command is not intended as a 'database' export, and may not output data in a format suitable for use with a database, nor for import back into iGrafx. It is a Tabular format export, suitable for humans to read in an application such as Excel.

You may also import data from any ODBC-compliant database, which includes Excel spreadsheet files, using the Tools menu Database Import command. The command will walk you through a wizard that will setup the import of your data. However, please note some important rules when importing data from Excel; particularly if you have exported data from a diagram in tabular format using the Tools > Export Table command:

  1. You cannot create shapes that do not already exist; every row of data in Excel must match up with an already existing shape in the iGrafx diagram.
  2. You must pick a unique field name (property key), such as shape ID, name, or number to map between your Excel data and the diagram.
  3. If you are attempting to import data that was exported with the Tools > Export Table command, you must first put that data in a format that is acceptable for importing from a database, or you could lose data on re-importing it. In particular, if the tabular export caused data to be spread across multiple
    lines, that data may be lost upon import.
  4. It's possible that Tools > Database Import on a file created with Tools > Export Table will appear to not work sometimes. For example, if you are trying to import Task page Duration times, and nothing happens. The reason for this is that Excel has a limitation and will return a “NULL” if the data you’re trying to import is of type “General”; i.e. it has a mix of data types. The workaround for this limitation in Excel is to do the following:
    1. In Excel, format the column as a single type; either Text (if it has expressions like “Between(30,90)”) or Number (if they’re all constant times). [Select the column, choose Format > Cells, choose the type (e.g. Text).]
    2. Ensure that Excel *really* sees your format change. One way to get this to happen is to edit another cell after this change. You can also force a cell to text by putting a single quote (?) in front of the data.

Finally, we again encourage you to read the Help system documentation on these commands before using them.

For Lean VSM diagrams, from the Lean menu choose Export VSM Table to Excel, or Import VSM Table from Excel. See the Help for more information.